Back to overview
Degraded

Severe Weather

Jan 24, 2026 at 05:59pm UTC
Affected services
Frontend
API
firestonefireacademy.xyz

Resolved
Jan 25, 2026 at 06:22am UTC

It appears all services response time is back to normal. There is still a possibility of the issue returning.

Updated
Jan 25, 2026 at 04:18am UTC

The situation seems to be improving. We will continue to monitor.

Created
Jan 24, 2026 at 05:59pm UTC

Severe weather is currently impacting the area the website is hosted. Traffic may be slow or intermittently unavailable.